Register  Login  Active Topics  Maps  

Learning with texts

  Tags: Software
 Language Learning Forum : Learning Techniques, Methods & Strategies Post Reply
353 messages over 45 pages: 1 24 5 6 7 ... 3 ... 44 45 Next >>
tommus
Senior Member
CanadaRegistered users can see my Skype Name
Joined 4054 days ago

979 posts - 1686 votes 
Speaks: English*
Studies: Dutch, French, Esperanto, German, Spanish

 
 Message 17 of 353
10 July 2011 at 7:48pm | IP Logged 
lwtproject wrote:
3. Make database updates as explained.

You show database updates for versions up to 0.5. Are there different update instructions for versions 0.6 and 0.7?

lwtproject wrote:
By the way: Can somebody explain to me how to post links here?


Click on the globe/link icon. Enter the link text and then the link URL. It always then places the link at the end of your edit page. You can move it with cut and paste.

1 person has voted this message useful



lwtproject
Pentaglot
Senior Member
Netherlands
lwt.sourceforge.net/
Joined 3080 days ago

148 posts - 260 votes 
Speaks: French, Dutch*, German, English, Mandarin
Studies: Italian

 
 Message 18 of 353
10 July 2011 at 8:05pm | IP Logged 
tommus wrote:
Are there different update instructions for versions 0.6 and 0.7?


No, the database has changed only from version 0.4 to 0.5 and from 0.5 to 0.6. I don't expect db changes in the
future.

Please read: http://lwt.sourceforge.net/#upgrade

My links will be removed because the forum don't trust me (new members are potential spammers here)...





Edited by lwtproject on 10 July 2011 at 8:21pm

1 person has voted this message useful



tommus
Senior Member
CanadaRegistered users can see my Skype Name
Joined 4054 days ago

979 posts - 1686 votes 
Speaks: English*
Studies: Dutch, French, Esperanto, German, Spanish

 
 Message 19 of 353
10 July 2011 at 9:43pm | IP Logged 
lwtproject wrote:
Upgrading in 3 simple steps:
1. Unpack the ZIP archive.
2. Copy everything but NOT the whole "media" dir and NOT the file "connect.inc.php" into the web server "lwt"
directory.
3. Make database updates as explained.

I have now done that twice, each time from 0.6 to 0.7. I then re-started the server. Both times, I got the following error:

Warning: include(connect.inc.php) [function.include]: failed to open stream: No such file or directory in C:\xampp\htdocs\lwt\index.php on line 11

Warning: include() [function.include]: Failed opening 'connect.inc.php' for inclusion (include_path='.;C:\xampp\php\PEAR') in C:\xampp\htdocs\lwt\index.php on line 11
DB select error

How does the media directory and the connect.inc.php file get rebuilt? Do you have to use those from the previous version? When I do that, I get the following error message and lwt does not work:

Invalid query: select StValue as value from settings where StKey = 'currentlanguage'



1 person has voted this message useful



tommus
Senior Member
CanadaRegistered users can see my Skype Name
Joined 4054 days ago

979 posts - 1686 votes 
Speaks: English*
Studies: Dutch, French, Esperanto, German, Spanish

 
 Message 20 of 353
10 July 2011 at 9:51pm | IP Logged 
lwtproject wrote:

Please read: http://lwt.sourceforge.net/#upgrade

My links will be removed because the forum don't trust me (new members are potential spammers here)...

Yes. I forgot about that rule. There have been a lot of such problems.

Here is that link:
http://lwt.sourceforge.net/#upgrade

I think HTLAL members would be interested in how you learned your spoken languages and how you are doing with your learning languages. Have you used a lot of computer-based language learning techniques?


1 person has voted this message useful



lwtproject
Pentaglot
Senior Member
Netherlands
lwt.sourceforge.net/
Joined 3080 days ago

148 posts - 260 votes 
Speaks: French, Dutch*, German, English, Mandarin
Studies: Italian

 
 Message 21 of 353
10 July 2011 at 11:17pm | IP Logged 
tommus wrote:
lwtproject wrote:
Upgrading in 3 simple steps:
1. Unpack the ZIP archive.
2. Copy everything but NOT the whole "media" dir and NOT the file "connect.inc.php" into the web server "lwt"
directory.
3. Make database updates as explained.

I have now done that twice, each time from 0.6 to 0.7. I then re-started the server. Both times, I got the following
error:

Warning: include(connect.inc.php) [function.include]: failed to open stream: No such file or directory in
C:\xampp\htdocs\lwt\index.php on line 11


Sorry for the problems. Maybe my English is/was not clear enough.

What I wanted to say:

KEEP (do not overwrite) ...
(1) the OLD database connection parameters .../xampp/htdocs/lwt/connect.inc.php and
(2) the whole OLD media sub-directory .../xampp/htdocs/lwt/media.

and UPGRADE everything else from the downloaded ZIP archive.
See the updated http://lwt.sourceforge.net/#upgrade

Hope that helps. I will think about a simpler upgrade process in the future......
1 person has voted this message useful



Michel1020
Tetraglot
Senior Member
Belgium
Joined 3205 days ago

365 posts - 559 votes 
Speaks: French*, English, Spanish, Dutch

 
 Message 22 of 353
11 July 2011 at 9:52am | IP Logged 
About the update, I do not understand why do you ask not overwriting the file : connect.inc.php ?
If there is a new version of a file - you have to replace the former version by the new one.
If there is no new version of a file - it will change nothing to replace the former version by an exactly identical new file. And this makes the update process look a bit more easy.

About my trouble with new french texts - The problem comes from the french letter à. As soon as this letter is in a text - this text is not accepted. I do not know if there are other letters with the same problem.

By the way I am talking about version 6.
1 person has voted this message useful



Michel1020
Tetraglot
Senior Member
Belgium
Joined 3205 days ago

365 posts - 559 votes 
Speaks: French*, English, Spanish, Dutch

 
 Message 23 of 353
11 July 2011 at 11:20am | IP Logged 
I try to modify

a-zA-ZÀ-ÖØ-öø-ÿœŒŸ from the languages base field LgRegexpWordCharacters
to
a-zA-ZÀ-ÖØ-öø-ÿœŒŸà
or to
àa-zA-ZÀ-ÖØ-öø-ÿœŒŸ
or to
a-zàA-ZÀ-ÖØ-öø-ÿœŒŸ

à still does not work. Any idea ? Thank you.
1 person has voted this message useful



lwtproject
Pentaglot
Senior Member
Netherlands
lwt.sourceforge.net/
Joined 3080 days ago

148 posts - 260 votes 
Speaks: French, Dutch*, German, English, Mandarin
Studies: Italian

 
 Message 24 of 353
11 July 2011 at 7:55pm | IP Logged 
a-zA-ZÀ-ÖØ-öø-ÿœŒŸ

does already contain everything in a French word!

"à" is already contained in the character range Ø-ö (U+00D8 ... U+00F6)
see http://www.unicode.org/charts/PDF/U0080.pdf

Why do want to modify this? Is "à" not recognized as part of words in your texts? That would be strange...

Edited by lwtproject on 11 July 2011 at 7:57pm



1 person has voted this message useful



This discussion contains 353 messages over 45 pages: << Prev 1 24 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45  Next >>


Post ReplyPost New Topic Printable version Printable version

You cannot post new topics in this forum - You cannot reply to topics in this forum - You cannot delete your posts in this forum
You cannot edit your posts in this forum - You cannot create polls in this forum - You cannot vote in polls in this forum


This page was generated in 0.3281 seconds.


DHTML Menu By Milonic JavaScript
Copyright 2019 FX Micheloud - All rights reserved
No part of this website may be copied by any means without my written authorization.